Retro Zone
help needed with PCSX2 1.4.0 - Printable Version

+- Retro Zone (https://retrozone.co/forums)
+-- Forum: Sony Playstation Series Forums (https://retrozone.co/forums/forum-27.html)
+--- Forum: Emulation (https://retrozone.co/forums/forum-32.html)
+---- Forum: PS2 (https://retrozone.co/forums/forum-110.html)
+---- Thread: help needed with PCSX2 1.4.0 (/thread-797.html)

Pages: 1 2 3


help needed with PCSX2 1.4.0 - Dragon Mech - 01-11-2019

hello.

a few days ago i got PCSX2 version 1.4.0 just to see if i could get it to run on my desktop.
however, during the initial setup the program couldn't find a SPU2 DLL file even though there was a dll named "spu2-x.dll".

is there something that i am missing or something missing from the install?


RE: hekp needed with PCSX2 1.4.0 - SasaPinjic - 01-11-2019

Dint have any problems when i instaled 1.4 version.
On other hand,i already had 1.1 and  1.2 versions instaled,so maybe setups are transfered from them ?

In any case, i sugest you also instaled thise versions as well,some games work with new versions and some with old ,and it is not like having all 3 emulators will take up much space on HDD, right ?  Big Grin
Also, did you trow in BIOS in emulator ?


RE: hekp needed with PCSX2 1.4.0 - Zerohour2k12 - 01-11-2019

There was at time that happened to me too, back when I was on Win XP, what i did was I downloaded an SPU2X.dll that compatible for that OS at the time... Big Grin
I still have it, 
Here ya go!
I hope it works out!


RE: hekp needed with PCSX2 1.4.0 - Rodion2018 - 01-11-2019

Instead of installing, you can just download the archive and extract it, without the need for installation:

https://pcsx2.net/download/releases/windows.html


But 1.4 is over 2 years old now, so you should try using the 1.5 version instead, there were a lot of updates. You can get it here:

https://buildbot.orphis.net/pcsx2/



RE: hekp needed with PCSX2 1.4.0 - Dragon Mech - 01-11-2019

ok i tried zerohour2k12's file and that didn't work.
so i downloaded the latest build of pcsx2 from the url that Rodion posted and my win xp says that the exe is not a valid win32 application
i think i'll try getting an eariler version and see what happends.


RE: hekp needed with PCSX2 1.4.0 - Dildo_Schwaggins - 01-11-2019

If your comp can handle it I would recommed windows 7 64 bit.
If it cant handle that, you are going to have a very slow pcsx2 experience.

I have i3 3.4ghz and radeon hd 7790 and pcsx2 runs slow in 1080p. I run it 720p
in double native res

earlier version is actually better because it supports DX9, which is the fastest renderer.
I believe I use 1.2.1

but usually i play it on authentic ps2 on 27" crt.


RE: hekp needed with PCSX2 1.4.0 - Zerohour2k12 - 01-11-2019

(01-11-2019, 09:12 PM)Dragon Mech Wrote: ok i tried zerohour2k12's file and that didn't work.
so i downloaded the latest build of pcsx2 from the url that Rodion posted and my win xp says that the exe is not a valid win32 application
i think i'll try getting an eariler version and see what happends.
Well that's a bummer, I downloaded that SPU2X from the PCSX2 site too....

More Info on that Problem Here

What system are you running on and is it 32 or 64 bit????
Some of the later builds tend to only support 64-bit nowadays....
(01-11-2019, 09:25 PM)Dildo_Schwaggins Wrote: If your comp can handle it I would recommed windows 7 64 bit.
If it cant handle that, you are going to have a very slow pcsx2 experience.

I have i3 3.4ghz and radeon hd 7790 and pcsx2 runs slow in 1080p.  I run it 720p
in double native res

earlier version is actually better because it supports DX9, which is the fastest renderer.
I believe I use 1.2.1

but usually i play it on authentic ps2 on 27" crt.
I agree, before I upgraded to Windows 7 64-bit, I only used 1.2.1 and 1.3.5(svn)
It's the most stable on lower-end systems and I still use it now from time to time....
Now i have 1.4.0 cuz for some reason, it won't recognize the plugins.....  Undecided


RE: hekp needed with PCSX2 1.4.0 - Dragon Mech - 01-12-2019

i downloaded pcsx2 version PCSX2 1.2.1 (r5875) and got it to work after i did some adjustments to the video options
but i can't fingure out how to get the emulator to load games from my real discs

EDIT: @Dildo_Schwaggins : i do have a better rig with win7 64-bit. but it needs a new 300W PSU just to get running with the current hardware configuration


RE: hekp needed with PCSX2 1.4.0 - Nux - 01-12-2019

(01-11-2019, 03:29 AM)Dragon Mech Wrote: hello.

a few days ago i got PCSX2 version 1.4.0 just to see if i could get it to run on my desktop.
however, during the initial setup the program couldn't find a SPU2 DLL file even though there was a dll named "spu2-x.dll".

is there something that i am missing or something missing from the install?

Are you trying to run PCSX2 from the archive? You need to extract it first. PCSX2 1.4 requires VC 2015 and that plugin alone requires VC 2013, do you have vc 2013 installed(x86/x64....I don't know which is needed based on the OS type)


RE: hekp needed with PCSX2 1.4.0 - Dragon Mech - 01-12-2019

no. i used the installer for version 1.4.0 and 1.2.1. and the installers include VC in them.
but as i stated in my last post. i have gotten version 1.2.1 to work. but i can't figure out how to get it to read a real PS2 disc from my DVD drive.